Intermittent issues with connection to ZetaSafe
Incident Report for ZetaSafe
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 20:23 BST
Monitoring
We are continuing to monitor - system performance now showing as normal
Posted Apr 24, 2024 - 18:07 BST
Investigating
We are currently investigating an issue where users are having difficulty connecting to ZetaSafe and mobile sync. We will update shortly
Posted Apr 24, 2024 - 17:43 BST
This incident affected: Website and ZetaMobile.